Jak używać funkcji SUMA.JEŻELI w Excel

By barutowicz|15/07/2018|Excel, Fromuły|0 komentarze

Jak używać funkcji SUMA.JEŻELI w Excel? Jeśli masz do czynienia z zadaniem, które wymaga od Ciebie zsumowania wartości według kryteriów to przy użyciu tej funkcji zrobisz bez problemu.

W tym wpisie postaram się przybliżyć składnie funkcji SUMA.JEŻELI jej ogólne zastosowanie, następnie wykorzystamy funkcje do rozwiązania kilku przykładów.

Jak używać funkcji SUMA.JEŻELI w Excel – składnia i użycie

Funkcja składa się z dwóch wymaganych argumentów oraz jednego opcjonalnego.

Jak używać funkcji SUMA.JEŻELI w Excel argumenty

Zakres – zakres komórek w których ma być sprawdzany twój warunek np A1:A10

Kryteria – warunek który będzie sprawdzany w zakresie, może to być liczba, tekst, data, wynik innej formuły, warunek może być wpisany bezpośrednio do funkcji lub może być pobierany z komórki. Przykładowe warunki “>5” , “mleko”, “15.07.2018”, “B1”

Zwróć uwagę że warunki tekstowe lub warunki które zawierają jakieś symbole matematyczne muszą być ujęte w cudzysłów ()

Suma_zakres – zakres komórek które mają być sumowane jeśli warunek jest spełniony.Ten argument jest opcjonalny musisz go podać tylko wtedy gdy chcesz sumować komórki inne niż zdefiniowane w “Zakres

Poniżej przykład z użyciem funkcji suma.Jeżeli w Excel:

Naszym celem jest zsumowanie wartości komórek z kolumny C” w przypadku gdy nazwa naszego produktu znajdującego się w kolumnie “A” to MLEKO kryterium to jest pobierane z komórki “H1” 

Zakres : A2;A7 (tutaj znajdują się nazwy naszych produktów)

Kryteria : H1 z tej komórki jest pobierana nazwa naszego produktu dla której chcemy policzyć stany magazynowe

Suma_zakres: C2:C7 (w tych komórkach znajdują się nasze stany magazynowe)

Naszą formułę należy zapisać:

=SUMA.JEŻELI(A2:A7;H1;C2:C7)

Jak używać funkcji SUMA.JEŻELI w Excel przykład zastosowania

Jak używać funkcji SUMA.JEŻELI w Excel – przykład formuły

Mam nadzieje że powyższy przykład pomógł zrozumie Ci zasady działania funkcji SUMA.JEŻELI. Poniżej zostaną przestawione różne przykłady zastosowania tej funkcji z rożnymi typami danych.

Funkcja Suma.JEŻELI większy niż, mniejszy lub równy

Poniżej w tabeli zostały przedstawione przykłady których możesz użyć aby zsumować wartości większych niż, mniejszych lub równych podanej wartości.

KryteriaPrzykład zapisuOpis
Suma jeżeli większe niżSUMA.JEŻELI (B2:B10;“>5”)Sumuje wartość komórek jeśli wartość jest większa niż 5
Suma jeżeli mniejsze niżSUMA.JEŻELI (B2:B10;“<5”)Sumuje wartość komórek jeśli wartość jest mniejsza niż 5
Suma jeżeli równeSUMA.JEŻELI (B2:B10;“=5”)Sumuje wartość komórek jeśli wartość jest równa 5
Suma jeżeli nie równeSUMA.JEŻELI (B2:B10;“<>5”)Sumuje wartość komórek jeśli wartość jest różna 5
Suma jeżeli większe niż bądź równe SUMA.JEŻELI (B2:B10;“>=5”)Sumuje wartość komórek jeśli wartość jest większa bądź równa 5
Suma jeżeli mniejsze niż bądź równeSUMA.JEŻELI (B2:B10;“<=5”)Sumuje wartość komórek jeśli wartość jest mniejsza bądź równa 5

Operator zawsze należy ująć w cudzysłów np. “<”

Poniżej użycie funkcji suma.jeżeli dla wartości korek które są większe bądź równe 5

=SUMA.JEŻELI(A1:A12;“>=”&5)

Jak używać funkcji SUMA.JEŻELI w Excel przykład zastosowania funkcji z liczbami

Kolejnym przykładem może być użycie funkcji suma.jeżeli wraz z funkcja max() lub min() które zwracają największą lub najmniejsza wartość w podanym zakresie a suma.jeżeli policzy wartość wszystkich wystąpień:

=SUMA.JEŻELI(A1:A11;MAX(A1:A11))

=SUMA.JEŻELI(A1:A11;MIN(A1:A11))

Jak używać funkcji SUMA.JEŻELI w Excel przykład zastosowania funkcji suma.jeżeli dla najmniejszej i największej wartości

Jak używać funkcji SUMA.JEŻELI w Excel z kryteriami tekstowymi

Oprócz kryteriów liczbowych funkcja daje również możliwość sprawdzania warunków tekstowych np. sumowania wartości tylko dla danego produktu.

Kilka przykładów poniżej w tabeli:

Kryteria Przykład zapisuOpis
Suma, jeśli równa sięDokładne dopasowanie:

=SUMA.JEŻELI (A2:A7;”Mleko”;C2:C7)

Zostaną zsumowane wartości wszystkich produktów których nazwa w komórkach od “A2” do “A7toMLEKO” wartości do sumowania będą pobierane z kolumny “C
Częściowe dopasowanie:

=SUMA.JEŻELI (A2:A7;”*Mleko*”;C2:C7)

Zostaną zsumowane wartości wszystkich produktów których nazwa w komórkach od “A2” do “A7zawiera słowo MLEKO” wartości do sumowania będą pobierane z kolumny “C
Suma, jeśli nie równa sięDokładne dopasowanie:

=SUMA.JEŻELI (A2:A7;”<>Mleko”;C2:C7)

Zostaną zsumowane wartości wszystkich produktów których nazwa w komórkach od “A2” do “A7to nieMLEKO” wartości do sumowania będą pobierane z kolumny “C
Częściowe dopasowanie:

=SUMA.JEŻELI (A2:A7;”<>*Mleko*”;C2:C7)

Zostaną zsumowane wartości wszystkich produktów których nazwa w komórkach od “A2” do “A7nie zawiera słowa MLEKO” wartości do sumowania będą pobierane z kolumny “C

Poniżej jeden przykład zastosowania “*

=SUMA.JEŻELI(A2:A7;”*Mleko“;C2:C7)

W tym przykładzie sumowane są wszystkie produkty które zawierają słowo “Mleko” na końcu.Jeżeli produkt nazywał by  się np “Mleko USA” to nie zostanie zsumowany ponieważ warunek nie zostanie spełniony.

Jak używać funkcji SUMA.JEŻELI w Excel przykład zastosowania funkcji suma.jeżeli z gwiazdką

 

Używanie operatorów porównania z odwołaniem do komórki

Jeżeli chcesz stworzyć formułę której kryterium jest pobierane z komórki to poniżej znajduje się przykład:

=SUMA.JEŻELI(A2:A7;“<>”&H1;C2:C7)

Tym razem nasza formuła sumuje wartości dla wszystkich produktów które nie nazywają sięMleko“(warunek <>). Jeśli chcieli byśmy wykluczyć inny produkt to wystarczy zmienić wartość komórki “H1

Jak używać funkcji SUMA.JEŻELI w Excel przykład wszystkie oprócz

Jak używać funkcji SUMA.JEŻELI w Excel z symbolami wieloznacznymi (?)

Powyżej został przedstawiony przykład z użyciem “*“, jednak możemy jako kryterium naszej funkcji również używać symboli “?” aby zastąpić pojedynczy znak tekstowy bądź kilka znaków tekstowych np “??”, “????a”

Przykład:

=SUMA.JEŻELI(A2:A8;“J????”;B2:B8)

Kryterium naszej funkcji to pierwsza litera “J oraz cztery zaniki za nią które wpisane są w postaci “????

Jak używać funkcji SUMA.JEŻELI w Excel przykład zastosowania funkcji suma.jeżeli z pytajnikiem

Jak podsumować komórki odpowiadające pustym komórkom

Kolejnym przykładem zastosowania funkcji suma.Jeżeli będzie użycie jej w celu policzenia wartości dla komórek które są puste.

W takim przypadku jako kryterium naszej funkcji należy wpisać znak “=” bądź tylko znaki znaki cudzysłowu “”

Przykład

=SUMA.JEŻELI(A2:A7;“”;C2:C7)

Jak używać funkcji SUMA.JEŻELI w Excel przykład zastosowania funkcji suma.jeżeli dla pustych komórek

Jak podsumować komórki odpowiadające niepustym komórkom

Jeśli chcesz sumować wartości komórek w kolumnie C, gdy odpowiednia komórka w kolumnie A nie jest pusta, użyj “<>” jako kryterium w formule

=SUMA.JEŻELI(A2:A7;“<>”;C2:C7)

Powyższa formuła zlicza wartości odpowiadające wszystkim niepustym komórkom, w tym ciągom o zerowej długości.

Jak używać funkcji SUMA.JEŻELI w Excel z datami

Używanie funkcji z datami nie różni się bardzo od powyższych przykładów z liczbami czy tekstem.

Jeżeli chcesz sumować wartości odpowiadające datom które są większe, mniejsze, równe itp użyj operatorów porównania które znajdą się w tym artykule powyżej.

Poniżej zostanie przedstawiony przykład z użyciem formuły Dziś()

Wynikiem takiej funkcji codziennie będzie odpowiadał aktualnej dacie.

SUMA.JEŻELI(B2:B7;DZIŚ();C2:C7)

Jak używać funkcji SUMA.JEŻELI w Excel Przykład sumowanie daty funkcja dziś

Jak sumować wartości w danym zakresie dat

Pytanie to jest często zadawane na forach i blogach, poniżej zostanie przedstawiony przykład zapisu funkcji SUMA.JEŻELI której wynikiem będzie sumowanie wartości z przedziału dwóch dat.

Polega to na użyciu kombinacji, a dokładniej różnicy między dwoma funkcjami Suma.Jeżeli

=SUMA.JEŻELI(B2:B7;”>=14.07.2018“;C2:C7)SUMA.JEŻELI(B2:B7;”>=16.07.2018“;C2:C7)

Ta formuła podsumowuje wartości w komórkach C2: C7, jeśli data w kolumnie B zawiera się między 14.07.2018  a 16.07.2018 włącznie.

Jak używać funkcji SUMA.JEŻELI w Excel przykład zapisu formuły dla sumowania wartości między datami

Mam nadzieje że ten wpis pomoże zrozumieć Ci jak działa funkcja SUMA.JEŻELI w Excel a powyższe przykłady były pomocne. Oczywiście to nie są wszystkie możliwe zastosowania tej funkcji. Jeśli masz jakieś pytania, problemy, pomysły, uwagi to napisz w komentarzu a postaram się na niego odpowiedzieć.

Zapraszam również do zapoznania się z funkcja licz.jeżeli jest ona podobna.

Udostępnij znajomym:

Dodaj komentarz