Jak używać funkcji LICZ.JEŻELI w Excel

By barutowicz|08/07/2018|Excel, Fromuły|1 komentarze

Jak używać funkcji LICZ.JEŻELI w Excel? Funkcja ta służy do liczenia różnych rodzajów komórek. Dzięki zastosowaniu funkcji Licz.Jeżeli możemy np. zliczyć puste lub niepuste komórki, komórki zawierające liczby,datę, tekst, zawierające określone słowa lub znaki możliwości jest bardzo dużo.

W tym wpisie najpierw krótko zostanie omówiona składnia i ogólne zastosowanie funkcji LICZ.JEŻELI a następnie wykonamy kilka przykładów.

Funkcja LICZ.JEŻELI w Excel – składnia i użycie

Funkcja LICZ.JEŻELI w EXCEL służy do zliczania komórek z określonym kryterium w zdefiniowanym przez nas zakresie.

Funkcja Licz.Jeżeli argumenty

Można np użyć tej formuły aby zliczyć ile komórek w arkuszu zawiera liczbę mniejszą, większą niż podana liczba w formule. Innym zastosowanie może być np. zliczenie ile razy dane słowo, litera występuje w naszych danych.

Budowa LICZ.JEŻELI jest bardzo prosta i składa się tylko z dwóch argumentów

=LICZ.JEŻELI(zakres;kryteria)

Innymi słowy

=LICZ.JEŻELI(Gdzie chcesz szukać?; Co chcesz znaleźć?)

Przykład

=LICZ.JEŻELI(B2:B10;”>100″)

Przykład użycia funkcji licz.jeżeli Excel

W tym przykładzie nasza formuła zlicza ile komórek w zakresie od B2 do B10 ma wartość większą niż 100

Przykłady użycia funkcji  LICZ.JEŻELI w Excel

Składnia funkcji Licz.Jeżeli jest bardzo prosta.Jednak funkcja ta pozwala użyć wiele rożnego typu kryteriów co sprawia że funkcja ta jest bardzo przydatna i często znajduje zastosowanie w pracy z Excelem. Poniżej zostaną przedstawione przykłady zastosowania.

Jak używać funkcji LICZ.JEŻELI w Excel dla tekstu i liczb (dokładne dopasowanie)

Funkcja LICZ.JEŻELI działa zarówno z wartościami tekstowymi i mogą to być litery, pojedyncze słowa jak również zdania oczywiście funkcja działa również z liczbami tak jak to było zademonstrowane w powyższym przykładzie. W tym przykładzie będziemy zliczać ilość wystąpień osoby w naszej liście a kryterium będzie pobierane z komórki “F2” i będzie to  Imię i Nazwisko osoby szukanej.

Zapis formuły:

=LICZ.JEŻELI(B2:B10;F2)

Gdzie:

B2:B10 To lista w której szukamy

F2 To wartość której wystąpień szukamy w naszej liście

Jak używać funkcji LICZ.JEŻELI w Excel funkcja licz.jeżeli wynik dla Imie i Nazwisko

W tym przykładzie “Jan Kowalski”(Komórka F2) występuje dwa razy w naszej liście (B2 do B10) i taki też jest wynik naszej formuły.

Jak używać funkcji LICZ.JEŻELI w Excel ze znakami wieloznacznymi (częściowe dopasowanie)

Tym razem zmodyfikujemy trochę powyższy przykład i będziemy chcieli zliczyć wszystkich “Kowalskich” na naszej liście.Aby tego dokonać użyjemy “*” zamiast Imienia w naszych kryteriach. Co oznacza dla naszej formuły że ma zliczyć wszystkie komórki które kończą się na “Kowalski”

Zapis naszej formuły się nie zmienia jedynej zmianie ulega kryterium.

Wynik działania:

Jak używać funkcji LICZ.JEŻELI w Excel wynik działania funkcji licz.jezeli z gwiazdka

Możemy również zapisać nasze kryterium z “*” tyłu wtedy otrzymamy nasza formuła zwróci wynik 0.

Jak używać funkcji LICZ.JEŻELI w Excel wynik działania funkcji licz.jezeli z gwiazdka z tyłu

Kolejną możliwością jest zapis naszej szukanej wartości z gwiazdką z przodu i z tyły *a* tym sposobem policzymy wszystkie komórki w których występuje litera a

Jak używać funkcji LICZ.JEŻELI w Excel wynik działania funkcji licz.jezeli z gwiazdka z tyłu i przodu

Funkcja LICZ.JEŻELI dla zliczania pustych i niepustych komórek

Jeżeli napiszemy naszą formułę w odpowiedni sposób możemy również zliczyć wszystkie puste komórki bądź wszystkie komórki które nie są puste poniżej przykłady jak za pomocą formuły LICZ.JEŻELI wykonać powyższe zadanie.

Jak używać funkcji LICZ.JEŻELI w Excel aby policzyć niepuste komórki

Najprostszym sposobem na znalezienie niepustych komórek będzie zapisanie naszej formuły LICZ.JEŻELI z użyciem “*” poniżej przykład takiego zapisu

=LICZ.JEŻELI(B2:B10;“*”)

Jednak tym sposobem zliczmy tylko te komórki które zawierają tekst, komórki które będą zawierały datę, liczby nie zostaną policzone.

Jeżeli chcesz zliczyć wszystkie niepuste komórki musisz użyć zapisu <>”&” poniżej przykład

=LICZ.JEŻELI(B2:B10;”<>”&”“)

Jak używać funkcji LICZ.JEŻELI w Excel Przykład licz.jeżeli niepustepola

Jak używać funkcji LICZ.JEŻELI w Excel aby policzyć puste komórki

Jeżeli chcesz zliczyć wszystkie puste komórki możesz przy użyciu funkcji LICZ.JEŻELI możesz zapisać formułę zgodnie z poniższym przykładem. W kryteria należy wpisać “”

=LICZ.JEŻELI(B2:B10;“”)

Jednak w Excelu istnieje funkcja LICZ.PUSTE() która jest do tego zadania przeznaczona.

Funkcja LICZ.JEŻELI większy niż, mniejszy lub równy

Aby policzyć komórki o wartościach większych niż, mniejszych lub równych podanej liczbie, wystarczy dodać odpowiedni operator do kryteriów, jak pokazano w poniższej tabeli.

KryteriaPrzykład zapisuOpis
Większe niżLICZ.JEŻELI(B2:B10;“>5”)Zlicz komórki których wartość jest większa niż 5
Mniejsze niżLICZ.JEŻELI(B2:B10;“<5”)Zlicz komórki których wartość jest mniejsza niż 5
RówneLICZ.JEŻELI(B2:B10;“=5”)Zlicz komórki których wartość jest równa 5
Nie równeLICZ.JEŻELI(B2:B10;“<>5”)Zlicz komórki których wartość jest nie jest różna 5
Większe niż bądź równe LICZ.JEŻELI(B2:B10;“>=5”)Zlicz komórki których wartość jest większa bądź równa 5
Mniejsze niż bądź równe LICZ.JEŻELI(B2:B10;“<=5”)Zlicz komórki których wartość jest mniejsza bądź równa 5

Operator zawsze należy ująć w cudzysłów np. “<”

Poniżej przykład zapisu funkcji LICZ.JEŻELI która zlicza komórki których wartość nie jest równa 1

Jak używać funkcji LICZ.JEŻELI w Excel przykład zapisu różne od 1

Jak używać funkcji LICZ.JEŻELI w Excel z datami

Jeżeli chcesz wykorzystać funkcje LICZ.JEŻELI aby policzyć np komórki w których występuje konkretna data sposób zapisu jest bardzo podobny do zapisu z liczbami.

Poniżej kilka przykładów wraz z opisem:

LICZ.JEŻELI(B2:B10;“06.07.2018”)

Zostaną zliczone wszystkie komórki w których data pokrywa się z datą wpisaną jako kryteria.

LICZ.JEŻELI(B2:B10;“>=06.07.2018”)

Zostaną zliczone wszystkie komórki w których data jest większa bądź równa z datą wpisaną jako kryterium.

LICZ.JEŻELI(B2:B10;“>=”&B2-“7”)

Zostaną zliczone wszystkie komórki w których data jest większa bądź równa z datą wpisaną do komórki B2 pomniejszona o 7 dni

Możemy również połączyć funkcje LICZ.JEŻELI z funkcją np. DZIŚ()

LICZ.JEŻELI(B2:B10;DZIŚ())

Zostaną zliczone wszystkie komórki których data jest równa bieżącej dacie.

Mam nadzieje że ten wpis pomoże zrozumieć Ci jak działa funkcja LICZ.JEŻELI a powyższe przykłady były pomocne. Oczywiście to nie są wszystkie możliwe zastosowania tej funkcji . Jeśli masz jakieś pytania, problemy, pomysły, uwagi to napisz w komentarzu a postaram się na niego odpowiedzieć.

Zapraszam również do zapoznania się z funkcja  Suma.Jeżeli
Udostępnij znajomym:

1 komentarz

  1. Super artykuł,
    pozdrawiam

Dodaj komentarz