Jak używać funkcji Jeżeli Excel

By barutowicz|07/07/2018|Excel, Fromuły|0 komentarze

Opis funkcji Jeżeli Excel

Jest to jedna z najbardziej popularnych i najczęściej używanych funkcji w Excel.

Funkcja ta sprawdza w pierwszej kolejności nasz warunek a następnie w jeżeli warunek jest spełniony wykonuje czynność jaka zostanie ustawiona dla wartości PRAWDA bądź wykonuje czynność która została przypisana dla wartości fałsz.

Funkcja Jeżeli może być łączona z funkcjami logicznymi, takimi jak ORAZ i LUB.

Funkcja jeżeli argumenty

Składnia

JEŻELI(test_logiczny;[wartość_jeżeli_prawda];[wartość_jeżeli_fałsz]

Innymi słowy

JEŻELI (Sprawdź warunek; [wykonaj to działanie jeżeli warunek jest prawdziwy], [wykonaj to działanie jeżeli warunek jest nieprawdziwy])

Przykład

=JEŻELI(B2>A2;“Jedziesz za szybko.”;”Odpowiednia prędkość”)

Przykład funkcji jeżeli excel

W tym przykładzie sprawdzamy czy wartość komórki “B2” jest większa od wartości “A2”. W naszym przykładzie jest to prawda i jako wynik z funkcji otrzymujemy “Jedziesz za szybko”.

 

Funkcja JEŻELI Excel  – rzeczy do zapamiętania!

Mimo że ostatnie dwa warunki funkcji są opcjonalne i mogą zostać pominięte to nie powinno się tego robić bo działanie funkcji będzie inne poniżej kilka przykładów.

 

Jeśli wartość_jeżeli_prawda zostanie pominięta

Jeżeli pominiemy wartość_Jeżeli_prawda i zapiszemy formułę w taki sposób =JEŻELI(G2>10;;“Przegrana”)  to w przypadku gdy warunek naszej funkcji zostanie spełniony to w wynikiem będzie “0” a nie pusta komórka.

Jeżeli chcesz żeby w wyniku pojawiła się pusta komórka dla spełnionego warunku należy w parametrze wartość_jeżeli_prawda wpisać (“”) w tym wypadku formuła zwróci puste pole =JEŻELI(G2>10;” “;“Przegrana”)

Wyniki działania dla tych przykładów:

Przykład jeżeli prawda puste

 

Jeśli wartość_jeżeli_fałsz zostanie pominięta

W przypadku gdy nie wpiszemy parametru wartość_jeżeli_fałsz a po parametrze nie wartość_jeżeli_prawda nie damy (;)  =JEŻELI(G2>10;“Gratulacje”) to wynikiem takiej funkcji w przypadku gdy warunek nie zostanie spełniony będzie “FAŁSZ” 

Jeżeli pominiemy wartość_Jeżeli_fałsz i zapiszemy formułę w taki sposób =JEŻELI(G2>10;”Gratulacje;)  to w przypadku gdy warunek naszej funkcji zostanie spełniony to w wynikiem będzie “0” a nie pusta komórka.

Najlepszym sposobem jest nie pomijanie warunków a używanie sposoby z (“”).W takich wypadkach zawsze mamy pustą komórkę.

Przykład wyniku działania:

Instrukcja Jeżeli, może również wykonać operacje matematyczne i zwrócić wynik

Zamiast zwracać określoną wartość możemy wykorzystać funkcje jeżeli do sprawdzenia konkretnych warunków a następnie w zależności od wyniku testu funkcja można wykonać dla nas rożne zadania matematyczne bądź wykonać inna instrukcję poniżej przykład:

=JEŻELI(A1=B1;SUMA(C1:H1))

W tym wypadku funkcja porówna komórkę A1 z komórka B1 i jeżeli wartości tych komórek będą takie same to zostanie użyta funkcja SUMA() która zsumuje nam wartości od komórki C1 do komórki H1. W innym wypadku czyli gdy wartość komórki A1 będzie inna od B1 to funkcja zwróci “FAŁSZ”

=JEŻELI(A1=B1;C1*5;C1-5)

W tym wypadku funkcja porówna komórkę A1 z komórka B1 i jeżeli wartości tych komórek będą takie same to wynikiem funkcji będzie pomnożenie wartości komórki C1*5. Jeżeli wartość porównywanych komórek będzie różna to funkcja zwróci wartość komórki C1 pomniejszoną o 5

Łączenie funkcji jeżeli z funkcjami LUB i ORAZ

W niektórych przypadkach np jeżeli chcemy sprawdzić dwa warunki za jednym razem możemy połączyć naszą funkcje JEŻELI z funkcją ORAZ

=JEŻELI(ORAZ(A1=B1;Q1>1000);”PREMIA“;”BRAK“)

W tym przypadku muszą zostać spełnione dwa warunki komórki A1 i B1 muszą być równe oraz wartość komórki Q1 musi być większa od 1000 tylko wtedy funkcja jeżeli zwróci wartość “PREMIA” w pozostałych przypadkach zwróci BRAK nawet jeżeli jeden z warunków będzie spełniony.

=JEŻELI(LUB(A1=B1;Q1>1000);”PREMIA“;”BRAK“)

W tym przypadku wystarczy że zostanie spełniony jeden z warunków czyli albo wartość  komórki A1 i B1 będzie równa lub  wartość komórki Q1 będzie  większa od 1000 to wystarczy aby funkcja jeżeli zwróci wartość “PREMIA”

Operatory logiczne

W poniższej tabli zostały przedstawiane operatory logiczne które mogą być wykorzystywane w funkcji JEŻELI.

WarunekOperatorPrzykład formułyOpis
Większe niż>=JEŻELI(A1>10;”OK”;”NOK”)Jeżeli wartość komórki A1 większa od 10 to wpisz “OK” w innym wypadku wpisz “NOK”
Mniejsze niż<=JEŻELI(A1<10;”OK”;”NOK”)Jeżeli wartość komórki A1 mniejsza od 10 to wpisz”OK” w innym wypadku “NOK”
Równe==JEŻELI(A1=10;”OK”;”NOK”)Jeżeli wartość komórki A1 równa 10 to wpisz”OK” w innym wypadku “NOK”
Nie równe<>=JEŻELI(A1<>10;”OK”;”NOK”)Jeżeli wartość komórki A1 inna niż 10 to wpisz”OK” w innym wypadku “NOK”
Większe niż bądź równe>==JEŻELI(A1>=10;”OK”;”NOK”)Jeżeli wartość komórki A1 większa bądź równa 10 to wpisz “OK” w innym wypadku wpisz “NOK”
Mniejsze niż bądź równe=<=JEŻELI(A1=<10;”OK”;”NOK”)Jeżeli wartość komórki A1 mniejsza bądź równa 10 to wpisz”OK” w innym wypadku “NOK”

Przykład zastosowania funkcji JEŻELI dla wartości tekstowych

Głównie wykorzystanie w tym wypadku funkcji JEŻELI to porównanie dwóch ciągów znaków ze sobą.

=JEŻELI(B2=”Dostarczone”;”NIE”;”TAK”)

W tym przykładzie porównujemy tekst wpisany do komórki B2 z tekstem “Dostarczone” jeżeli ciągi znaków są identyczne to funkcja zwróci nam wartość “NIE” w pozostałych przypadkach otrzymamy “TAK”. Wielkość liter jest nie brana pod uwagę również. Jednak wystarczy np. spacja na końcu a nasza funkcja już zwróci fałsz.

Funkcja jeżeli używana z tekstem

Aby uniknąć problemu ze znakiem spacji w naszym tekście możemy zapisać nasza  funkcje JEŻELI z połączeniem funkcji USUŃ.ZBĘDNE.ODSTĘPY() dzięki temu nasz tekst który trafi do sprawdzania nie będzie posiadał już zbędnych spacji.

Przykład takiej funkcji:

=JEŻELI(USUŃ.ZBĘDNE.ODSTĘPY(B2)=”Dostarczone”;”NIE”;”TAK”)

Przykład zastosowania funkcji JEŻELI dla daty

Mogło by się wydawać że zastosowanie funkcji JEŻELI dla daty są identyczne jak dla pozostałych przykładów które zostały opisane powyżej, niestety tak nie jest.

W przeciwieństwie do wielu innych funkcji, JEŻELI nie rozpoznaje datę i interpretuje je jako ciąg znaków tekstowych dlatego też nie można jej używać w tak prosty sposób jak >”07.07.2018″ albo =07.07.2017. Żadne z tych użyć nie zadziała prawidłowo.

Dlatego aby funkcja Excel Jeżeli zadziałała prawidłowo dla naszej daty musimy użyć dodatkowej funkcji DATA.WARTOŚĆ(). Zastosowanie w praktyce wygląda tak:

=JEŻELI(DATA.WARTOŚĆ(“07.07.2018”);PRAWDA;FAŁSZ)

Poniżej zdjęcie jak funkcja JEŻELI zadziała z funkcja DATA.WARTOŚĆ oraz jak zadziała bez niej:

zastosowanie funkcji jeżeli dla daty

Jak widać wynik funkcji jest całkowicie inny.

 

Mam nadzieje że ten wpis pomoże zrozumieć Ci jak działa funkcja JEŻELI a powyższe przykłady były pomocne. Oczywiście to nie są wszystkie możliwe zastosowania tej funkcji JEŻELI. Jeśli masz jakieś pytania bądź problemy napisz w komentarzu a postaram się na niego odpowiedzieć.

Udostępnij znajomym:

Dodaj komentarz